~/2019/05/10

Connecting to NTT East's VDSL with an OpenWRT router and NTT's VDSL modem

The modem that NTT offers operates in bridge mode by default.

OpenWRT's /etc/config/network looks like this:

  config interface 'loopback'
          option ifname 'lo'
          option proto 'static'
          option ipaddr '127.0.0.1'
          option netmask '255.0.0.0'

  config globals 'globals'
          option ula_prefix 'fd28:186c:2088::/48'

  config interface 'lan'
          option ifname 'eth1'
          option force_link '1'
          option type 'bridge'
          option proto 'static'
          option ipaddr '192.168.1.1'
          option netmask '255.255.255.0'
          option ip6assign '60'

  config interface 'wan'
          option ifname 'eth0'
          option proto 'pppoe'
          option username 'thing-i-received-from-asashi-net'
          option password 'secret'

After /etc/init.d/network reload, the PPPOE negotiation should take place and the WAN should be available.